$re = '/.*\|[\s]*(.*?)[\s]*$/';
$str = 'CLR Podcast | 013 | Adam Beyer ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);