package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<aaa>.+),(?<bb>.+),(?<cc>.+),(?<dd>.+),(?<ee>.+),(?<ff>.+),(?<gg>.+),(?<hh>.+),(?<ii>.+),(?<jj>.+),(?<kk>.+),(?<ll>.+),(?<mmm>.+),(?<nn>.+),(?<oooo>.+)`)
var str = `f1,f2,f3,f4,f5,f6,f7,f8,f9,f10,f11,f12,f13,f14,f15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}