$re = '/\D+\d{4}\K/';
$str = 'ABCDE1234ABCD1234ABCDEF1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);