$re = '/#(?:[0-9A-Fa-f]{6}|[0-9A-Fa-f]{3})(?=;|[^(]*\))/mi';
$str = '#BED, #foo
{
color: #FfFdF8; background-color:#aef;
font-size: 123px;
background: -webkit-linear-gradient(top, #f9f9f9, #fff);
}
#Cab
{
background-color: #ABC;
border: 2px dashed #fff;
}
#BED, p {
color: #ABC;
@media( min-width: 420px) {
color: #ABC;
}
}
#BED { background: url(http:xyz.com)}
#BED { background: url(http:xyz.com) color: #ABC; }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);