import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)(?:(?=[\\d. -]{11}(?!\\d))\\d{1,}([. -])\\d{1,}\\1\\d{1,}|\\d{9})(?!\\d)";
final String string = "222-33-4444\n"
+ "333.77-8888\n"
+ "111 77.9998\n"
+ "111 22 3333\n"
+ "11-222222-9\n"
+ "a222-33-4444\n"
+ "222-33-4444b\n"
+ "111223333\n"
+ "ssn:123456789 or\n"
+ " ssn#123456789\n"
+ "123-456789\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}