import re
regex = re.compile(r", услуги,[^;]+;")
test_str = "1. Иванов Иван Иванович - оказываются услуги проживания (2-х местный двухкомнатный Люкс, Основное место), услуги питания (Заказное меню), медицинские услуги (Лечение), услуги, связанные с организацией туристического путешествия; 2. Петров Пётр Петрович - оказываются услуги проживания (2-х местный двухкомнатный Люкс, Дополнительное место), услуги питания (Заказное меню), услуги, связанные с организацией туристического путешествия (без оказания медицинских услуг); 3. Семенов Семён Семёнович - оказываются медицинские услуги (Лечение), услуги, связанные с организацией туристического путешествия (без оказания услуг проживания, услуг питания);"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")