package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\x{3040}-\x{30ff}\x{3400}-\x{4dbf}\x{4e00}-\x{9fff}\x{f900}-\x{faff}\x{ff66}-\x{ff9f}\x{3040}-\x{30ff}\x{3400}-\x{4dbf}\x{4e00}-\x{9fff}\x{f900}-\x{faff}\x{ff66}-\x{ff9f}\x{3131}-\x{D79D}]`)
var str = `2009年,波音公司(Boeing)在查尔斯顿附近的新厂破土动工时,曾宣扬这里是最先进的制造中心"
",将制造一款世界上最先进的飞机。但在接下来的十年里,这家生产787梦想客机的工厂一直受到做"
"工粗糙和监管不力的困扰,危及航空安全。
(電腦用中文字型與字碼對照表, 技術通報C-26
"MojiJoho-Kiban Project" (文字情報基盤整備事業)
General Chinese Standard Dictionary (通用规范汉字字典)
Macao Information System Character Set (澳門資訊系統字集)
化學命名原則(第四版) (Chemical Nomenclature: 4th Edition)
Hanyo-Denshi Program (汎用電子情報交換環境整備プログラム)
Unifiable variants and exact duplicates in Extension B
Also in CJK Unified Ideographs Extension B, hundreds of glyph variants were encoded.[13] In addition to the deliberate encoding of close glyph variants, six exact duplicates (where the same character has inadvertently been encoded twice) and two semi-duplicates (where the CJK-B character represents a de facto disunification of two glyph forms unified in the corresponding BMP character) were encoded by mistake:[14]
U+34A8 㒨 = U+20457 𠑗 : U+20457 is the same as the China-source glyph for U+34A8, but it is significantly different from the Taiwan-source glyph for U+34A8
U+3DB7 㶷 = U+2420E 𤈎 : same glyph shapes
U+8641 虁 = U+27144 𧅄 : U+27144 is the same as the Korean-source glyph for U+8641, but it is significantly different from the Chinese Mainland-, Taiwan- and Japan-source glyphs for U+8641
U+204F2 𠓲 = U+23515 𣔕 : same glyph shapes, but ordered under different radicals
U+249BC 𤦼 = U+249E9 𤧩 : same glyph shapes
U+24BD2 𤯒 = U+2A415 𪐕 : same glyph shapes, but ordered under different radicals
U+26842 𦡂 = U+26866 𦡦 : same glyph shapes
U+FA23 﨣 = U+27EAF 𧺯 : same glyph shapes (U+FA23 﨣 is a unified CJK ideograph, despite its name "CJK COMPATIBILITY IDEOGRAPH-FA23.")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}