package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$\d+(?:\.\d+)?|(\d+(?:\.\d+)?)`)
var str = `The cost of 2 burgers and 3 drinks are $15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}