using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+?(?=[^\x00-\x7F]).*(?=\n)\n";
string substitution = @"";
string input = @"A.我不要这些汉字
Ok I see
有人会懂我写的吗?
Why not then?
我看够呛。
This is just an example";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}