import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Encryption Algorithms:(\\w+-\\w+(?:,\\w+-\\w+)*)";
final String string = "SSH Enabled - version 2.0\n"
+ "Authentication methods:publickey,keyboard-interactive,password\n"
+ "Encryption Algorithms:aes128-ctr,aes192-ctr,aes256-ctr,aes128-cbc,3des-cbc,aes192-cbc,aes256-cbc\n"
+ "MAC Algorithms:hmac-sha1,hmac-sha1-96\n"
+ "Authentication timeout: 120 secs; Authentication retries: 3\n"
+ "Minimum expected Diffie Hellman key size : 1024 bits\n"
+ "IOS Keys in SECSH format(ssh-rsa, base64 encoded):";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}