package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)embed\/(.*?)(?:\?|$)`)
var str = `https://www.youtube.com/embed/f2fJsDFJ23?autoplay=1
https://www.youtube.com/embed/f2fJsDFJ23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}