re = /^(?<is_hidden>\.?)(?:(?<timestamp>\d+)\-)?(?<name>[\w\x27\s]+\-?)+\-(?<content_removed_version>\d+(?:\(\w+\))?)(?<extensions>[\.[[:alpha:]]+\.?)*$/
str = '2023-make_test-00.make'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end