#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+55)?[\s]?\(?(\d{2})?\)?[\s-]?(9?\d{4}[\s-]?\d{4})$"
Local $sString = "+55(16)91555-3456" & @CRLF & _
"22 98671 1032" & @CRLF & _
"+55 7134764819" & @CRLF & _
"(23)99378-4366" & @CRLF & _
"+5598683 1021" & @CRLF & _
"+551199603-3412" & @CRLF & _
"55 98214 9064" & @CRLF & _
"(55)98330-7156" & @CRLF & _
"(82) 936147156" & @CRLF & _
"+552430431084" & @CRLF & _
"2140028922" & @CRLF & _
"40028922" & @CRLF & _
"21 40028922" & @CRLF & _
"(21) 4002-8922" & @CRLF & _
"+55 21 4002 8922" & @CRLF & _
"+55(21)4002-8922" & @CRLF & _
"+55986320291"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")