package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?x)(?-i:class)\s+[A-Za-z_$][\w$]*\s*\{`)
var str = `class Entity
{
constructor(game,imageURL)
{
this.game = game;
this.sprite = new Sprite(this.game.c,imageURL);
}
draw(depth,offset,textureSize,textureCoordinates,offsetX=0)
{
let scaleFactors = {
1:1,
2:0.65,
3:0.45
};
let scaleFactor = scaleFactors[depth];
let x = Math.floor(offset.x + textureCoordinates[0] + (textureSize[0] / 2) - (this.sprite.image.width * scaleFactor / 2));
let y = Math.floor(offset.y + textureCoordinates[1] + (textureSize[1] / 2) - (this.sprite.image.height * scaleFactor) + 6 * scaleFactor);
x = x + offsetX * scaleFactor;
let width = Math.floor(this.sprite.image.width * scaleFactor);
let height = Math.floor(this.sprite.image.height * scaleFactor);
let entityFades = {
1:1,
2:0.5,
3:0.1
}
let filter = '';
if(this.game.level.entities.fadeType === 'darken')
{
filter += 'brightness('+entityFades[depth]+')';
}
this.sprite.draw(
x,
y,
width,
height,
0,
0,
this.sprite.image.width,
this.sprite.image.height,
filter
);
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}