re = /^(?=.*IDAILDA)^(?=.*282610\/SP)^Processo.*/m
str = 'Processo 1001959-75.2018.8.26.0028 - Divórcio Consensual - Dissolução - S.M.R.A.S. - Ofício e Mandado de Averbação disponíveis para retirada pelo interessado (fls. 30/31). - ADV: IDAILDA APARECIDA GOMES (OAB 282610/SP)
Processo 1002033-32.2018.8.26.0028 - Inventário - Inventário e Partilha - Maria das Graças de Souza Andrade - Jaqueline de Souza Andrade - - Raquel de Souza Andrade - Aguarde-se o recolhimento do imposto causa mortis. - ADV: LUIZ GUSTAVO CAVALHEIRO FERREIRA (OAB 240154/SP), ANTONIO AUGUSTO CALTABIANO ELYSEU (OAB 239669/SP)
Processo 0000995-65.2019.8.26.0028 (processo principal 1000841-98.2017.8.26.0028) - Cumprimento de sentença - Perdas e Danos - Adriano Teixeira Guimarães - Silvestre Pelegrini Batista - VISTOS. Expeça-se guia de levantamento do valor depositado, intimando-se a parte autora/exequente. Em seguida, transitada a presente em julgado e nada mais sendo requerido, arquivem-se os autos com as cautelas devidas. P. R. I. C. - ADV: IDAILDA APARECIDA GOMES (OAB 282610/SP), MARIA APARECIDA SOUSA GAY MAROTTA (OAB 91666/SP), HUGO VALLE DOS SANTOS SILVA (OAB 181789/SP)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end