$re = '/\/u\/([^/]+)/mi';
$str = '/u/some_user/create/initial
/u/some_user/create';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);