$re = '/@([A-Z0-9]+-)*[A-Z0-9]{2,}\.[A-Z0-9]{2,63}$/mi';
$str = 'a@b.com
a@bb.com
a@b-domain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);