const regex = new RegExp('(?:\\s+(?:Incorporated|Corporation|Company|Inc Common Stock|QQQ|ETF|PLC|SA|Inc|Corp|Ltd|LP|plc|Group|The|Co|International))+\\s*$', 'gmi')
const str = `Woori Finance Holdings Co Ltd
Alliance One International Inc`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);