$re = '/(?:\s*(\d+)x(\w+)\s*)+/m';
$str = '1xFBBC\', float(\'nan\'), 3xBCDV';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);