$re = '/^(?!\d*$|[a-z]*$)[a-z\d]+$/mi';
$str = '123
abc
a1
2b
...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);