package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ErrorCode\(([\d,]+)\)`)
var str = `ErrorCode(1,2,3,4,5,6)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}