$re = '/([\'\"]?)\?.*?;\1/m';
$str = 'This is param-start ?abcdef; param-end
This is param-start "?abcdef;" param-end
This is param-start \'?abcdef;\' param-end
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);