$re = '/\/command\s?\S(\.\S+)?/';
$str = '/command 1
/command 0.5
/command 0.123456789
/command a
/command a.bcded
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);