$re = '/(\-?\d+(?:\.\d+)?)\,\s*(\-?\d+(?:\.\d+)?)/m';
$str = '24.03729, -100.7821427';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);