$re = '/(<script)(>[\s\S]+window.__PRELOADED_STATE__)/m';
$str = ' <script>
window.__PRELOADED_STATE__';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);