const regex = /^\d{11}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{11}$', 'gm')
const str = `12345678987
123456789876
1234 5678987
11223344556
A1234B5678987`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}