$re = '/[0-5]?\d:[0-5]?\d:[0-5]?\d\.\d{1,2}/';
$str = '23:59:59.34666
56:59:59.34666';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);