package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https:\/\/cdn07\.icims\.com\/a\/images\.icims\.com\/content\/platform_[0-9\.]+\/script[\/[a-z0-9\/]+\.js`)
var str = `https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/lib/domreplacement/domreplacement.js
https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/common/icims.js
https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/portal/utils.js`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}