$re = '/(?:[ED]=\s*)?(?:\d+\s*X\s*)*\d+\s*(?:M[MG]|KG/M)/m';
$str = '\'EXTRUDED PROFILE 50 X 50 MM\', \'MATERIAL TYPE 3XP WITH A DENSITY OF D= 50KG/M3 AND THICKNESS OF E=8MM\', \'STEEL TUBE 50X50X3 MM\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);