$re = '/^.*error.*$/m';
$str = 'word1 word1 word1 word word3 wordesd sdfsdf error dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfswdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsdr sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word rword3 wordsd error rsdfsdf dsf sword1 words2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd rsdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word wored3 wordsd error sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word wordr3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 woerd1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);