$re = '/([^\/]+\/?)$/m';
$str = 'example.com/dies-das-jenes
www.example.com/dies-das-jenes
https://www.example.com/dies-das-jenes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);