$re = '/^[0-9]$|^[1][0-9]$|^[2][0-4]$/m';
$str = '0
1
10
20
24
25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);