$re = '/(\w+)(?=\W+(\w+))/m';
$str = 'This is a test pattern to show that this stuff works blah blah blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);