import re
regex = re.compile(r"^(?!\t)(?:(FULL|SMALL)\W*)?([^\n]+)(.+?)(?=^(?!\t)\w+?|$(?!\n))", flags=re.MULTILINE | re.DOTALL)
test_str = ("\n\n"
"Gahriel and Diana are standing in the living room. \n\n\n\n"
"FULL: The living room has SOFA and a table. On the table have CUPCAKE and a NOTE at the bottom (or somewhere that doesn’t present the first time we see it.) Gahriel is walking to the kitchen calling out his mom.\n"
" Gahriel\n"
" Make yourself at home!\n"
" Diana \n"
" okay!\n"
" Gahriel\n"
" (calling out his mom)\n"
" Mom?\n"
" Where is she?\n\n\n"
"SMALL- Diana inside the living room with Gabriel. She’s amazed with the picture on the wall related to his mother and young Gahriel. \n\n"
" Diana ask\n"
" Is this you and your mom?\n\n"
" Gahriel (smiling)\n"
" Haha, yup.\n"
" That’s me.\n\n\n\n"
"Diana (yelling and laughing so loud and keep talking)\n"
" Diana\n"
" Argh.. that’s so cute.\n"
" Look at how chubby you are!\n")
subst = "<div class=\"PANEL $1\">\\n<div class=\"action\">$2</div></div>\\n\\n"
result = regex.sub(subst, test_str)
if result:
print(result)