$re = '/\bP[0-9A-Z]{2}\b/i';
$str = 'PCC, PC4, PCA, P00A, pc~, pca';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);