# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d+=\s*({(?:(?:{(?:(?:{(?:(?:{(?:(?:{(?:(?:{(?:(?:{(?:(?:{(?:(?:{[^}{]*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})"
test_str = ("1111= \n"
"{ \n"
"name=\"NY\" \n"
"owner=\"USA\" \n"
"controller=\"USA\" \n"
"core=\"USA\" \n"
"garrison=100.000 \n"
"artisans= \n"
"{ \n"
"id=172054 \n"
"size=40505 \n"
"american=protestant \n"
"money=5035.95938 \n"
"} \n"
"clerks= \n"
"{ \n"
"id=17209 \n"
"size=1988 \n"
"nahua=catholic \n"
"money=0.00000 \n"
"} \n"
"}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.