const regex = new RegExp('(AK|BK)([A-Za-z-/]+[0-9]+)|([0-9]+[A-Za-z-/]+)', 'g')
const str = `This is the organization..this is the address.
AKBN
some information
AK3418CPMP
lot of other information down
BKCPU
tester
BKAT309548`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}