re = /;|,(?=[a-z])/m
str = 'column1;column2;column3,column4,column5
1,234;2,665;0,888;3,891;3,762
2,232;1,233;0,888;3,789;3,524'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end