$re = '/([ ](?![^(]*\)))/m';
$str = 'apple bottom cotton dog (eagle fox gut) horse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);