$re = '/,\s*(?=(?:(?:[^"]*"){2})*[^"]*$)/m';
$str = 'a,b,c,d,e
a,b,"c,d", e
a,,"c,d", e
xz a,, b, c, "d, e, f", g, h';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);