const regex = /^(?=[a-zA-Z].{6})[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[a-zA-Z].{6})[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)?$', 'gm')
const str = `Somename
S0mename
Somenamehereanditisia-averylong0ne
-Somename
Some-name-
S0me--name
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}