re = /[\x00-\x1F\x7F<>:"\/\\|?*]/m
str = 'match newline
match tab
does not match space
mactch char "*/:<>?\\|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end