$re = '/^(.{31})(.*)$/';
$str = 'This is a 😅 👨💻 🇧🇷 🏳️🌈 string';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);