// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"xmin = (\S+)\s+xmax = (\S+)\s+text = "([^"]*)"#).unwrap();
let string = "intervals [1]:
xmin = 0
xmax = 13.139997023062838
text = \"\"
intervals [2]:
xmin = 13.139997023062838
xmax = 14.763036269953904
text = \"Cities are like siblings in a large polygamous family.\"
intervals [3]:
xmin = 14.763036269953904
xmax = 17.01
text = \"\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}