re = /([a-zA-Z0-9._-]+@([a-zA-Z0-9_-]+\.)+[a-zA-Z0-9_-]+)/
str = ' 112761085640459 vk@mail.ru 1487935670 1517859074'
# Print the match result
str.match(re) do |match|
puts match.to_s
end