re = /^(2[0-3]|[01][0-9]):([0-5][0-9]):([0-5][0-9])(\.[0-9]+)?(Z|[+-](?:2[0-3]|[01][0-9]):[0-5][0-9])?$/m
str = '09:00:00+07:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end