re = /'(?:[sdmt]|ll|ve|re)| ?\p{L}+| ?\p{N}+| ?[^\s\p{L}\p{N}]+|\s+(?!\S)|\s+/m
str = 'Ġmeousrtr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end