package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(java|test|dev)\b`)
var str = `java
javascript`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}