$re = '~^[A-Z](?:(?!__)(?!_$)[A-Z\d_])+$~mi';
$str = 'name_1
name__2
_name3
name4_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);