$re = '/(?<emoji>(:)([a-zA-Z0-9_]+)(:))|(?<embed_emoji>(\[)([a-zA-Z0-9_]+)(\])\([^()]*\))/m';
$str = ':emojisomeothertext:
:someothertextemoji:
:someemojiothertext:
:emoji:
text with no emoji
text with :emoji_some_text: and no emoji
text with :emoji:
text with [ImageEmoji]
These image [emoji]\'s were added due to vesktop making emojis into embeds like that.
This regex isn\'t perfect but i doubt anyoue would post emojis like: "[this:" anyway.
[HuTaoPeek](https://cdn.discordapp.com/emojis/844898526243586049.webp?size=512&name=HuTaoPeek)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);